[kget/frameworks] Fix dependencies

Review Request #129337 - Created Nov. 4, 2016 and submitted

Andreas Sturmlechner
aspotashev, lappelhans, uwolfer

Add some missing ones, drop duplicate, sort/re-arrange.

Switch to Gpgmepp, Qgpgme from GpgME
boost::shared_ptr -> std::shared_ptr

Adjust to use new KF5::Torrent cmake target

Cleanup old libktorrent ifdefs



  • 0
  • 0
  • 1
  • 1
Description From Last Updated
Andreas Sturmlechner
Alexander Potashev
Andreas Sturmlechner
Andreas Sturmlechner
Review request changed

Status: Closed (submitted)

Change Summary:

Submitted with commit a03385b5f1dcaa8eb1e1fb6fe6a478cc1ee07006 by Andreas Sturmlechner to branch frameworks.
Alexander Potashev

CMakeLists.txt (Diff revision 2)

After this change CMake is unable to find kf5-gpgmepp-devel-16.08.2-1.fc24.x86_64. I guess this can be fixed by trying both "KF5Gpgmepp" and "Gpgmepp".

  1. Well that's on purpose, since KF5Gpgmepp is EOL'd with 16.08.3 and gpgme-1.7.1 can be installed side-by-side just fine already.

  2. A solution to work with both would look similar to the commit in kwallet.git: https://quickgit.kde.org/?p=kwallet.git&a=commit&h=60ebcad53c95ecfbe822647075f79578c3420851

    But while I see the purpose for Frameworks to stay compatible with older dependencies (so in theory LTS distros 'could' upgrade Frameworks) I would rather not clutter the kget frameworks branch with that.

  3. Does that mean you need to require minimum gpgme version 1.7.1, like "find_package(Gpgmepp 1.7.1)"?

  4. Technically no, but it might make things a bit clearer for packagers as to why configure fails with <gpgme-1.7.0. Gpgmepp and QGpgme were released first with 1.7.0 as optional bindings, but some important fixes went into 1.7.1 which is why I like to recommend that version.

  5. Please make things clearer :)