[plugins/qpa] support use of modularized qtplatformsupport from Qt 5.8

Review Request #129268 - Created Oct. 27, 2016 and submitted

Information
Takahiro Hashimoto
kwin
master
Reviewers
kwin
graesslin

QtPlatformSupport is now modularized in the latest 5.8 branch [1] This change causes build failure of KWin on include/library path finding(QtFontDatabaseSupport, QtEventDispatcherSupport, QtThemeSupport)

This patch fixes build issue, finding platformsupport modules correctly.

[1] https://codereview.qt-project.org/#/c/172485/

Now running make test(taking a few long time). I should be update the result of test here.

Martin Flöser
Takahiro Hashimoto
Takahiro Hashimoto
Aleix Pol Gonzalez
Takahiro Hashimoto
Review request changed

Status: Closed (submitted)

Change Summary:

Submitted with commit 052fa2e4ee329810f62c29e546254fb45bf8a375 by Takahiro Hashimoto to branch master.
Loading...