Some cleanup in the applet and the KCM
Review Request #127710 - Created April 22, 2016 and submitted
Branche "cleanup" here : git://anongit.kde.org/clones/plasma-pa/laissus/plasma-pa.git
- Move sourceIndex and sinkIndex properties to a generic one called deviceIndex in the Stream class.
It helps us to remove the deviceType checks in the KCM (DeviceComboBox)
- Drop sub component support for list items of the applet as it's not used anymore
As we discussed in a previous RR, it's not planned to use this component so let's clean this up !
I also unified source and sink list items into a generic one.
Ported to FontMetrics. I wasn't aware of this class, a very elegant way to solve this problem !
It would also be interesting to unify the two volume sliders (same code) but they have different types.
Is this suitable to use a Plasma Slider in the KCM ?
Revision 3 (+53 -261)
Status: Closed (submitted)
Submitted with commit 8cf44b34fbc6fdac78887f1f4cc65837672f7691 by Yoann Laissus to branch master.