[kdesvn] Use context specific structures instead generic
Review Request #126973 - Created Feb. 2, 2016 and submitted
Some svn callbacks are using a generic structure to pass the data. I changed this to use specific structures to avoid casting to/from void*
void * bad, this change good. Just two comments.
Is there any reason why the excludelist is a ctor param and not the other fields -- or none of them?
It just seems a bit unbalanced.
Ah, probably because the member is a const ref. This is... potentially dangerous. When someone passes a value to a ctor that takes a const ref, they don't expect to have to ensure that the lifetime of the value will be sufficient (equal or greater than the lifetime of LogBaton).
Copying a StringArray seems fast enough to me, I'd make the member a value rather than a ref.
OK the alternative is to make it a pointer again, like all the other members here. Then the calling code knows it has to ensure lifetime of the object, since it's calling & on it and letting LogBaton store that.
Or is the copy ctor for StringArray unavailable? Strange.
man this code is hard to read, with "date", "date_" and "date__" ... Maybe date__ can be renamed time_t_date or something ? Or the member variable date should use the type apr_time_t and then it can be passed directly to this function call? Dunno.