Only install konqpopupmenuplugin.desktop in kde-baseapps if the KF5 version is less than 5.16

Review Request #125995 - Created Nov. 8, 2015 and submitted

Information
Frank Reininghaus
kde-baseapps
frameworks
Reviewers
kde-baseapps
dfaure

KIO installs this file since version 5.16.

Even if the frameworks branch of lib/konq is currently unreleased, resolving this file installation conflict makes life easier for those who package it (reported in https://bugs.kde.org/show_bug.cgi?id=353642#c12 )

kde-baseapps does not try to install the file any more. If I artificially increase the checked version to 5.17, it does try, so I'm confident that this will work fine with KIO versions prior to 5.16 and install the file (which is needed to make the context menu for files work properly in Dolphin, FolderView, Konqueror, etc.).

David Faure
Frank Reininghaus
Review request changed

Status: Closed (submitted)

Change Summary:

Submitted with commit b919367c8550024aca53c7f4d219a5b4c3317964 by Frank Reininghaus to branch frameworks.
Loading...