Adjust to newer upstream libhybris version

Review Request #125606 - Created Oct. 12, 2015 and submitted

Information
Martin Flöser
kwin
master
812fb4a...
Reviewers
kwin
davidedmundson, mart

Based on a previous patch done by David Edmundson and heavily
inspired by qt5-qpa-hwcomposer-plugin [1].

The change requires a newer libhybris than the one used by Ubuntu. In
fact it allows to build against current master (at the day of writing [2]).

[1] https://github.com/mer-hybris/qt5-qpa-hwcomposer-plugin
[2] https://github.com/libhybris/libhybris/commit/bd6df6a3064f50df326a4644cc7660c0a587b50e

Running on Nexus 5, looks like tearing is fixed (I know I shouldn't write that, that just makes bad bits to produce tearing again).

Marco Martin
David Edmundson
Martin Flöser
Martin Flöser
Review request changed

Status: Closed (submitted)

Change Summary:

Submitted with commit 28fe78a94f7d833eb2624300c409aca0d08cc3c8 by Martin Gräßlin on behalf of Martin Graesslin to branch master.
Loading...