Make KF5 based okular coinstallable with KDE4 version

Review Request #124381 - Created July 18, 2015 and submitted

Information
Alex Richardson
okular
frameworks
a1cd91f...
Reviewers
okular
aacid

Install Okular5Config.cmake instead of OkularConfig.cmake

Otherwise Qt4 projects that have a find_package(Okular) can break
because CMake then selects moc from Qt5 which won't work


Make the KF5 okular library coinstallable with the KDE4 version

The KF5 based library has been renamed to libOkular5Core.so so that
both can coexist in /usr/lib(64)


Set the CMake target name from Okular::okularcore to Okular::Core

Patched Kile to use find_package(Okular5), everything seems to work

Issues

  • 1
  • 0
  • 0
  • 1
Description From Last Updated
What is EXPORT_NAME? Albert Astals Cid Albert Astals Cid
Albert Astals Cid
Albert Astals Cid
Alex Richardson
Review request changed

Status: Closed (submitted)

Change Summary:

Submitted with commit 5ecffc246b6e00441386cbd0c107a19432ffe3b9 by Alex Richardson to branch frameworks.
Loading...