Bump minimum cmake version to 2.8.6, use AUTOMOC in any case

Review Request #124333 - Created July 12, 2015 and submitted

Information
Dennis Nienhüser
marble
master
Reviewers
marble

At the moment we're keeping compatibility with cmake 2.6. To be able to do that we have to run automoc in relaxed mode, which results in an annoying lot of warnings on the shell when generating moc files. Bumping the minimum cmake version requirement to 2.8.6 allows us to fix that and not run automoc in relaxed mode anymore, getting rid of all the warnings.

Cmake 2.8.6 was released in October 2011 and should be widespread enough. Debian stable for example ships 3.0.2. The reason we kept 2.6 support was to keep compatibility with Maemo. However I'd like to drop that now.

The patch is a tad lengthy, but really boils down to two changes:
get rid of the marble_qt4_automoc macro
change moc include calls to use foo.moc or moc_foo.cpp according to how automoc wants it (short: moc_foo.cpp => "please moc my header", foo.moc => "please moc me")

I intend to push this within some days if I get no feedback. So please speak up if you see a problem with this.

Build, compile, run with Qt5 and examples, tools and tests enabled.

Wouldn't mind somebody with Qt4 giving it a try.

Dennis Nienhüser
Review request changed

Status: Closed (submitted)

Change Summary:

Submitted with commit ba768c96d988086d0e600970715aa1db2117b78f by Dennis Nienhüser to branch master.
Loading...