Retry starting mysqld a few times. It always failed here.

Review Request #124264 - Created July 5, 2015 and discarded

Information
Andreas Hartmetz
akonadi
master
Reviewers
akonadi

Retry connecting to the MySQL server a couple of times.

For me it reliably failed at the version check, which is the first
query executed on a new connection. So apparently the connection
looked ready but wasn't. Looks like a problem in a lower layer
where I unfortunately couldn't find any suspicious changes.
I did not look lower than QtSql, though.

With this change, the connections usually succeeds at the fourth
attempt, which is about one second after the first.
My previous workaround was trying to start akonadi, obtaining
the mysqld start command with
"while true; do ps aux | grep mysqld ; done"
then starting mysqld manually, then akonadi. That worked
very reliably.

The akonadi server starts up again.
It worked briefly before, but now I couldn't start it anymore on two different machines. I made several attempts.

Sergio Martins
Andreas Hartmetz
Review request changed

Status: Discarded

Loading...