OpenChange should be als "required"

Review Request #122892 - Created March 10, 2015 and discarded

Information
Guy Maurel
akonadi-exchange
Reviewers
akonadi

As I don't have the OpenChange package (under ArchLinux) installed,
I get only an error from cmake:
CMake Warning at CMakeLists.txt:26 (message):
Exchange needs OpenChange MAPI Client Library.
The process goes on:
-- Generating done
-- Build files have been written to: /home/guy-kde/build/5/playground/pim/akonadi-exchange

But the generated files aren't correct.


  

Issues

  • 1
  • 0
  • 0
  • 1
Description From Last Updated
If libmapi is required in order to successfully compile akonadi-exchange, then find_package(OpenChange REQUIRED) should be used, instead of macro_optional_find_package. Same ... Daniel Vrátil Daniel Vrátil
Daniel Vrátil
Christophe Giboudeaux
Guy Maurel
Review request changed

Status: Discarded

Change Summary:

review closed. This project is dead.

Loading...