Use co-installable qca-qt5 version

Review Request #122155 - Created Jan. 19, 2015 and submitted

Information
Heiko Becker
okular
frameworks
Reviewers
okular

If both qt4 and qt5 versions of qca are present the build of the
frameworks branch tries to find Qt4 pulled in by qca and thus fails.

This is similiar to what has been done to konversation and muon
http://quickgit.kde.org/?p=konversation.git&a=commit&h=3aa918b5e3ac0f90a76d55c2bab12fafcbb1279b
http://quickgit.kde.org/?p=muon.git&a=commit&h=fd76f5ad43228689127cb4f12c0fbc6d65f4b373

Note: I don't have commit access so I'd need someone to push this for me.

Successfully built with -DCMAKE_DISABLE_FIND_PACKAGE_Qca-qt5:BOOL=FALSE AND TRUE and okular linked to the right version of qca in the former case.

Karol Herbst
Albert Astals Cid
Karol Herbst
Heiko Becker
Review request changed

Status: Closed (submitted)

Loading...