Fix CMP0053 warning with CMake 3.1.

Review Request #121971 - Created Jan. 10, 2015 and submitted

Information
Alex Merry
extra-cmake-modules
master
b46b04e...
Reviewers
extracmakemodules
dfaure

With CMake 3.1, @-style variable expansion is deprecated outside of
configure_file() or string(CONFIGURE) contexts (CMP0053). This causes
ecm_generate_pri_file() to produce dev warnings with this verison of
CMake, and would break this function in projects that set CMake 3.1 as
their required version.

Attica still configures and builds, and produces the same .pri file it did before.

David Faure
Alex Merry
Review request changed

Status: Closed (submitted)

Loading...