Greatly cleanup PluginController::loadPluginInternal.
Review Request #121881 - Created Jan. 6, 2015 and submitted
This hopefully resolves some issues in understanding the flow of this method. Some code could also be removed and the warning messages better formatted.
Looks good to me.
Stylistic nitpick: the if-statements aren't consistently formatted (spaces outside vs. inside the parentheses).
Also, while you guys are at it, do you think you could add some UI feedback for when loading a plugin fails? Currently, when a plugin fails to load, the only indication in the UI is that in the Plugins page of Configure KDevelop, the plugin becomes disabled - and it reverts to being disabled if one tries to enable it manually. That's really not ideal...
Still see no reason why you didn't remove checkForDependencies? IMO it makes things more complicated. You can do the same by using just loadDependencies.
Or at least you could have added a doxygen comment for checkForDependencies, or renamed it to e.g. hasUnresolvedDependencies. Because currently it's not clear what it does, and what returns in each situation.