Clean up all kateversion numbers according to XML validation

Review Request #120133 - Created Sept. 10, 2014 and submitted

Information
Martin Walch
ktexteditor
master
338787
Reviewers
kate

Since KDE 3.0, it is possible to update Kate highlighting files on a per user basis using a download dialog in the configuration menu, without the need to update the whole installation of KDE. To indicate compatibility, there is an attribute "kateversion" in the language element of the highlighting files. However, those values have become a mess over time.

This patch is a radical clean-up of the kateversion values, setting each of them to the lowest possible value that makes sure that compatibility is only indicated if the update validates with the shipped definition file (language.dtd).

Note that with this patch the latest

  • ample.xml
  • freebasic.xml
  • markdown.xml
  • maxima.xml
  • puppet.xml

will probably be unavailable as updates to KDE4 installations (the update to puppet.xml is currently unvailable to KDE4 anyway). Instead

  • agda.xml
  • jira.xml
  • kconfig.xml
  • k.xml
  • mediawiki.xml
  • q.xml
  • vala.xml

should become available.

BUG: 338787
REVIEW: 120133

Validation against historic dtd files.
Due to the lack of a KF5 installation, I have not revalidated all files against the language.xsd of KF5.
(Also no runtime tests.)

Christoph Cullmann
Martin Walch
Review request changed

Status: Closed (submitted)

Change Summary:

Submitted with commit 857a277110d514065392d670382d2cc5a13bb244 by Dominik Haumann to branch master.
Loading...