Disable the DDS and JPEG-2000 plugins when Qt version is 5.3 or later

Review Request #119590 - Created Aug. 3, 2014 and submitted

Information
Alex Merry
kimageformats
master
a56ecfb...
Reviewers
kdeframeworks
alexmerry

QtImageFormats 5.3 comes with DDS and JPEG-2000 plugins that support
more options and are generally better than our plugins. The only
advantage our plugins offer is that the Qt DDS plugin does not work on
sequential devices, while ours does. This is outweighed by other
improvements, though, such as supporting more variants.

(NB: I opted for disabling rather than removing because we want distros to push new KF5 versions back to stable distro versions, but they are probably not going to do the same with Qt 5.2 -> 5.3.

Built with Qt 5.3.1 - the JPEG-2000 and DDS plugins are not built, and the JPEG-2000 tests are not built or run.

Alex Merry
Alex Merry
Alex Merry
Alex Merry
Aleix Pol Gonzalez
Alex Merry
Review request changed

Status: Closed (submitted)

Loading...