[kio] Replace COULD_NOT with CANNOT in the error code enum
Review Request #117195 - Created March 30, 2014 and submitted
Use the new name for the error codes ERR_COULD_NOT_* has been replaced with ERR_CANNOT_*. Replace COULD_NOT with CANNOT in the error code enum This makes the error code names more consistent. The old versions are kept for backwards-compatibility.
Builds, tests pass.
Funny that somehow errno manages to never use "CAN" or "COULD" in its own error messages and descriptions. It actually manages to be much more precise about the reason for the failure, not just "this call failed". Oh well :)