Add Qt 5 support

Review Request #116583 - Created March 3, 2014 and submitted

Information
Pier Luigi Fiorini
polkit-qt-1
master
Reviewers
polkit-qt-1
dafre, dfaure
Add Qt 5 support

Autodetect the Qt version to use, preferring Qt 5 over Qt 4.
Users can force a Qt 4 build passing -DUSE_QT4:bool=ON to CMake.

For both builds the CMake minimum requirement is raised to 2.8.11,
which provides automoc support. This means that automoc4 support is
removed with this patch.

Qt 5 builds require ECM and use KDEInstallDirs to install libraries,
while Qt 4 builds keep using InstallSettings.

The CMake module now defines POLKITQT-1_INCLUDE_DIRS with the include
directory just like Qt 5 modules does.  It contains the same value
as POLKITQT-1_INCLUDE_DIR.

  

Issues

  • 0
  • 4
  • 0
  • 4
Description From Last Updated
Pier Luigi Fiorini
Hrvoje Senjan
Pier Luigi Fiorini
David Faure
David Faure
Pier Luigi Fiorini
Martin Bříza
Pier Luigi Fiorini
Dario Freddi
Dario Freddi
Commit Hook
This review has been submitted with commit ddca404a1b8214ee12d1d123ff289769458cfacb by Pier Luigi Fiorini to branch master.
Pier Luigi Fiorini
Review request changed

Status: Closed (submitted)

Loading...