find_dependency: Update to match CMake's version

Review Request #116080 - Created Feb. 26, 2014 and submitted - Latest diff uploaded

Information
Alex Merry
extra-cmake-modules
master
Reviewers
buildsystem, extracmakemodules, kdeframeworks
find_dependency: Update to match CMake's version

Specifically, we namespace the variables to avoid conflicts, and make
the version argument optional.
kdesrc-build with clean build and install dirs successful, using CMake 2.8.12 (and so using this version of find_dependency, rather than the one shipped with CMake 3.0).
Loading...