Porting KTranscript from KJS to QtScript

Review Request #115485 - Created Feb. 4, 2014 and submitted

Information
Kevin Krammer
ki18n
master
Reviewers
kdeframeworks
ilic
Attempt at replacing the KJS dependency with a QtScript, i.e. making ki18n a tier1 framework.
Needs more testing and likely fixing
Unittest runs, but the test script is very minimal and would need to be extendedb by someone who understands the scripting requirements.
There is also a weird crash at test shutdown, in QThreadStorage. As far as I can tell I did not change anything related to threads though.

Issues

  • 0
  • 3
  • 0
  • 3
Description From Last Updated
Aurélien Gâteau
Kevin Krammer
Kevin Krammer
Albert Astals Cid
Kevin Krammer
Kevin Ottens
Kevin Krammer
Chusslove Illich
Kevin Krammer
Chusslove Illich
Commit Hook
This review has been submitted with commit 6d405c31ac624b4ea8b7144a83cd3c04b3e38a25 by Kevin Krammer to branch master.
Kevin Krammer
Review request changed

Status: Closed (submitted)

Michael Palimaka
If this is tier 1 now, please don't forget to update the wiki and the yaml file.
  1. Also find_dependency(KF5JS "@KF5_VERSION@") can go away =)
  2. Both good catches. All in now
Loading...