Adding support for changing implicit settings

Review Request #102553 - Created Sept. 7, 2011 and submitted

Information
Thomas Balling Sørensen
polkit-kde-kcmodules-1
implicit-experimental
Reviewers
polkit-kde-kcmodules-1
dafre
Adding support for / fixed implicit setting editor.
I have done all sort of testing, by adding and removing both implicit and explicit settings.
All the different combinations of saving implicit and explicit settings I can think of seems to work fine.
Thomas Balling Sørensen
Review request changed

People:

+dafre
Dario Freddi
Awesome job. Please fix the comments below (mostly code-style related) and commit straight away.
helper/polkitkde1helper.cpp (Diff revision 2)
 
 
Would be nice to have this method named writeImplicitPolicy to retain consistency with the other one.
  1. Will be fixed :)
helper/polkitkde1helper.cpp (Diff revision 2)
 
 
I guess for this patch it's ok, but I'd really love to see in the future proper error management, so the helper might indeed return a value here.
  1. I agree. Have thought about that too.
helper/polkitkde1helper.cpp (Diff revision 2)
 
 
code style: NewName->newName. Use starting capital letter just for class names.
  1. I will change that one.
polkitactions/ActionWidget.h (Diff revision 2)
 
 
 
Please rename these methods: such a naming implies a signal. Usually, methods returning a boolean variable are called isSomething() or areSomething(). I guess isExplicitSettingsChanged() would fit better here.
  1. I will change that one.
polkitactions/ActionWidget.h (Diff revision 2)
 
 
 
 
 
 
 
Code style: name variables without underscores: the format should be m_explicitIsChanged.
Loading...